AlfieCloud is supported in the latest version of Google Chrome (which automatically updates whenever it detects that a new version of the browser is available) and the modern major releases of Firefox, Internet Explorer, and Safari on a rolling basis.

At Alfiesoft, we’re committed to developing modern & secure web applications and making use of new capabilities available in modern, up-to-date browsers. That’s why we made the decision when developing the AlfieCloud to support only modern browsers, which also provide improved security and performance.


Current Support includes:

Google Chrome

Firefox 20 >

Internet Explorer 10 & 11

Safari 4 >


Other browser versions may work, but there may be some functionality using new modern code that will not work correctly. If this is the case, please update to one of the modern browsers above.


All of the Alfie Tests still have full Browser support (Internet Explorer 7 and above).